
Adr_Html Version 1.0 Step by Step

This document is both a general reference manual and a hands on tutorial of Adr_Html. By 
following the steps listed here you will quickly learn the operation of Adr_Html and its features. 

When you load Adr_Html the sample database file demo.hdr will also be loaded.  This sample 
file is required for using the step by step tutorial examples.

GENERAL OVERVIEW:

Adr_Html is an address book program specifically designed to enhance personal 
communications on the Internet. The interface program is a graphical address book program 
which runs on Microsoft Windows and is compatible with Windows 95. Rather than producing 
labels and envelopes as a standard address book program does, Adr_Html produces 
customizable Html documents for each of your records. 

The significant advantage of an Html Address Book is that Email address and URLs entered 
for the record become clickable links when viewed with your Web browser. 

The Html documents created can be viewed by any browser that supports table tags.  Index 
Html pages are produced to access the individual records.  Several different styles of index 
are produced and most of these require Netscape 2.0 or later to access them.  There is one 
Html index scheme that allows for accessing with most any other browser.

CREATING THOSE HTML RECORDS:  

This is the heart of the program so I feel it best to cover this first. It will be assumed that you 
do have Netscape 2.0 to access the Html documents produced.

You should load Demo.hdr into Adr_Html for these examples.  Demo.hdr can be found in the
directory that contains your unpacked software.  If you received a disk containing the 
registered version of the software, it will be located on diskette. The first example will produce 
individual Html documents for each record in the demo.hdr file. An index Web page will also 
be produced. Netscape 2.0 is required to view this index Web page because it uses 
Netscapes' frame extension to Html.

1. From the File menu select Write Html Frame Col. Style... 

2. The dialog box titled Html Column List will present itself.  There are several options to be 
discussed in this dialog box but this will be saved for later. At this point you should have 
default settings.  The Do Header Frame check box should be checked and the Create all 
Records and Index Html radio button should be selected. If they are not, please set them. 
Now click on Write Files...

3. The standard save file dialog box should be presented. You should see the default filename:
framecol.htm. In the folders directories you should see pages. Double click on this to enter 
this folder or directory. Click on OK.

4. A helper dialog box should be on you screen.  This is just to remind you of  the HTML file 
name that you want to open with your Browser to view the HTML records that were just 
created. You should see the file name framecol.htm.  Checking the Never show this 
message again will prevent this helper dialog box from ever coming up again.  You can check
this if you want and then click on OK.

5. Bring up Netscape 2.0. (or later)



6. From the File menu of Netscape select Open File... Locate framecol.htm. and open the 
file.  If you did a default installation for Adr_Html you will find the file located in C:\adhtml10\
pages\framecol.htm. 

7. You should now see three Netscape frames.  A title frame, an index frame, and a data 
record fram.  The first record you should see is Scott Adams.  Click on Gardner, Michael in 
the index list on the left side. This will bring up the record that contains information on me.

8. If you are currently connected to the Internet, click on my Email address 
mikeg@alaska.net. This should bring up the Emailer associated with Netscape. (If this fails 
to bring up an Email window you will need to configure this in the Options/Mail and News 
Preferences of Netscape) Type any message and send it to me.  It will let me know that you 
actually read this. I'm not worried about being over burdened with Email :-)

9. Again if you are currently connected to the Internet, you can click on my URL: 
http://www.alaska.net/~mikeg/. This should bring up the Brown Bear Software home page.

Notice how there are clickable links to my Email address and URL in the NOTES area of the Html
Record.  If you look at the details of this record in Adr_Html you will see that nothing special has 
been has been added to make this happen. The free text of the NOTES field is scanned for http://
and the @ sign and converted to their appropriate links.

COMMENTS ON 'Write Html Frame Col. Style...' Dialog Box

Above we skipped a discussion of this dialog box. Let's take a moment to look at this. Bring up
this dialog box up by selecting  Write Html Frame Col. Style... from the File menu.

The field Html Title Line has the text People and Places.  This will be the Html title name 
used in the Index Web page that is produced. By default this is framecol.htm that was shown 
in the example above.  You will see this title name when you open framecol.htm with your 
Web Browser. This is also the text that you will see if you save the Web page in your Browser 
bookmarks.  You can change this text to anything that works well for you.

The next field that we see in the dialog box is Header Text. This is the text that will appear in 
the header frame of the Web index page when viewed with the browser. The header frame is 
optionally created. The check box Do Header Frame is used to determine if this header frame
should be displayed.  The header frame takes additional display area so you may not want to 
include this frame if you only have a 14" monitor. 

The next three fields; Header, Index, and Data Record Body Tag allow you to specify the 
Html Body take of the three corresponding frames created in the Web index page. You can 
enter anything here that is defined for the body tag in the HTML standard. You can set 
background color, add a background image to be used etc.  If you enter some incorrect 
statement, you can always get back to something that will work by clicking on the Default 
button.

An important selection is whether to produce Web pages for all Adr_Html records or to only 
produce the Index Web page.  The radio buttons,  Create all Records and Index Html and 
Index Html Only determine this.

If you had 350 entries in your Adr_Html database file,  producing  individual HTML record files
can be time consuming on some systems. Therefore you might not want to reproduce all of 
the individual records any more often than needed. If you add a new record to  Adr_Html you 
do not need to produce all of the individual records again.  All that you need to do is write a 
new HTML record for this newly added record. This is done by selecting  Writing Html Active 



Record...  (discussed below) from the File menu.  To be able to access this new record you 
need only to recreate the HTML index record. This done by selecting the Index Html Only 
radio button.  This concept is consistent across all output styles.

COMMENTS ON 'Write Html Frame Row Style...' Dialog Box

This dialog box is very similar to 'Write Html Frame Col. Style...'  discussed above. The 
primary difference between the two revolves around the Header frame. In this style, the 
header frame simply works as a column title to your selections from several check boxes.  
These check boxes allow you to display the Email Address, Work phone, Home phone, Cell
phone, and Fax numbers. 

Lets face it. The paragraph above will make little sense until you visually see the Html index 
Web page created by 'Write Html Frame Row Style... My suggestion is to follow the step by 
step description for 'Write Html Frame Col. Style... given above, but do it for the Row Style 
menu option. If you do this I then believe everything will become abundantly clear :-)

COMMENTS ON 'Write Html Simple Style...' Dialog Box

This dialog box is very similar to 'Write Html Frame Row Style...'  in many ways.  The 
significant difference is that this style does not produce Web page index that can only be 
viewed by Netscape 2.0 or later.  Any Web browser that can support the Html Table Tag 
standard can view the Web page produced by this option.

COMMENTS ON 'Write Html Active Record...' 

The 'Write Html Active Record...'  is a menu option under File. This will write the Web page 
for the currently selected record in Adr_Html. The selected record is the one that is 
highlighted with Turquoise. When you select this option the write file common dialog box will 
appear.  The default file name will be something like adam0019. Though you can change this 
name to anything, in most cases this would not be a good idea.  Any of the Web page indexes 
produced expect to find the individual record Web pages by the default name that appears.

NAVIGATION:  

This discusses basic movement within the Adr_Html Widows program.

1. Run the Adr_Html program.  If demo.hdr  does not come up, click on file, and open the file
demo.hdr from the file menu. 

2.  Click on any tab letter to take you to the first entry of that letter. For example, click on the 
black and yellow C tab. You should see the name Chicago Bulls appear in the upper left 
quarter of the address book. The name and address will be highlighted in turquoise. 

3.  The green arrows at the top of the screen move the highlight.  The single green arrow keys
move through the record names one at a time, while the double arrow keys move four at a 
time.   Using the mouse,  single click on the right green arrow. This should cause the name, 
IRS to be highlighted. Click the single arrow four more times and you will see the page turn 
with the name Resource Data Inc. highlighted.

4.  Any name can be brought up instantly by clicking on it in the list box to the right of the 
graphical address book.  Using the mouse, scroll through the list until you see my name, 
Michael Gardner.  Click on it with the mouse. You will immediately see the name appear 



highlighted in the upper left of the graphical display.

5. If you have many entries, the fastest way to reach a particular name is to drag the mouse 
over whatever name appears in the box above the list box.  When the name is thus 
highlighted, type the name you are seeking.  It will appear in the top left of the graphical 
display.  Type the letter B and you will see the name Baha'i Faith appear highlighted in the 
upper left corner of the address book. Now type the letter E.  The name selected will now be 
Beiley, Mark.   

6. Move the mouse to click on any part of the address within the graphical address book for 
Chu, Chirk. Notice how it now becomes the highlighted name. This is the means for making 
active any name visible on the address book.

EDITING /ADDING /DELETING and COPY:

1. Click on the A tab letter. Adams, Scott should appear highlighted in the upper left corner of
the address book. Using the mouse double click in any part of the turquoise area. This should 
bring you to Entry Form window containing all attributes for this record. Change the home 
telephone number from (745) -555-8933 to (745) -111-2222 Now click on OK and when the 
address book is redisplayed you should see this new home phone number.

2. Select the Edit button from below the list box. This will once again bring you to the Entry 
Form window. Click Cancel to go back to the address book. Now double click on the name 
Chu, Chirk in the list box. This also gets you to the editing dialog box. Once again select  
Cancel.  Now click on Edit from the pull down menu at the top of the window and select Edit. 
This is yet another way to get to the Edit Dialog Box. Select Cancel.  You can also type the 
accelerator key combination Ctrl+E to edit the currently active record.

3. Click on the A tab letter. Click on the Edit button to once again enter the Entry Form 
window. Click on the Add / Next button. This will cause the next record to be displayed, 
making it available for edit changes.  In this case, you will see the record for Alaska Railroad 
Click on the Add / Next button again and you will see the record for the Baha'i Faith appear. 
This is a good way to go through all of your records making many modifications. Click on 
Cancel to get back to the address book display.

4. To add a new entry into the database click on the Add button below the list box. This will 
bring up an empty Entry Form. Enter your last name and first name and fields of interest. If 
this is the only name you want to add click OK to get back to the address book.  If you want to 
add additional records select  Add / Next. For our example, click on Add / Next.  Notice how 
the form is cleared and is ready to receive data for the next record. Click on Cancel. You will 
now see the name you just entered highlighted in turquoise.  You could also get the Entry 
Form for adding by selecting the Add option under the Edit menu option or by typing the 
accelerator key combination, Ctrl+A. You might note that you do not need to enter a starting 
capital letter for either the First Name or Last Name. Adr_Book always forces the first 
character of these two fields to upper case when the form is saved.

5. To delete a record click on the Delete button below the list box. Do this now for the record 
you just added. You will get a pop up box asking if you really want to delete the record.  The 
record to be deleted is the one currently highlighted in turquoise. In this case it should be the 
name you just added. Respond  by selecting Yes.  You could also Delete a record by selecting
the Delete option under the Edit menu option or simply by pressing the Delete Key on your 
keyboard.

6. The Copy selection under the Edit pull down menu will copy the name and address from 
the currently active record to the clipboard. This allows you to easily move names and 
addresses into your favorite word processor. You could try this now by first selecting Copy 



from the pull down menu. Then go to the Microsoft supplied Write or Wordpad program and 
select Paste from the Edit pull down menu.  You will see the name and address lasted 
highlighted in turquoise appear in your document.

DISPLAY OPTIONS:

The display options control what record information will be shown on the graphical address 
book. 

1. Click on the Option menu item and then select Display.  From the dialog box click on the 
Work Phone check box, and the Email check box.  Now click on the OK box. You should see 
the work phone and Email appear in the graphical address book. Experiment with different 
data items that can be displayed.

2. The Notes free text information can be displayed from the graphical address book. To 
demonstrate this check the Note check box in the Display dialog box. (This may already be 
checked)  Click on OK to get to the graphical address book. Click on the A tab letter so you 
can see the Adams, Scott record. Notice the  word Note is highlighted in red.  This means 
that there is some free text associated with this record. If there is no Note text you will not see 
the highlighted Note.. word appear for the record. Now click anywhere in the red highlighted 
area. You can now click anywhere in the window and the list box will disappear. This is an 
easy way to bring up any additional information you decide to add for an individual.

MODE (USA/International) OPTION:

This option determines how the address portion of the record is formatted. USA mode has the 
address entry fields as two full lines of Address, a line for City, a place for State, and a place 
for Zip Code. International mode provides four full address lines, permitting the address to be
entered in any appropriate fashion. A single database file can accommodate both types of 
records.

1. Click on the Option menu item and then select Mode (USA/International).  This will bring 
up a dialog box that simply permits you to select a check box for USA or International mode. 
It also gives a rather winded explanation of the difference between the two modes. Click on 
the International mode check box. Then click on OK.

2. Click on the ADD button to create a new record.  When the Entry dialog box appears you 
will notice the Address entry block looks different. As described above, there are four full lines 
for entering the address. Go ahead and create a new record with any name. Then click on 
OK. 

3. Now you should see the new entry you created highlighted in turquoise. Get to the Edit 
entry screen by double clicking in the turquoise area. Notice that the address entry area still 
has four full lines (as you suspected).  Click on Cancel.

4. Now go to the entry screen of any of the other records in this sample database file. Notice 
how the Address lines have City, State, and Zip. Any new records that you add while in this 
mode will have the International style address mode. 

5. Click on the Option menu item and select Mode (USA/International). Click on the USA 
check box and then click on OK.  Now any new records that you add will have the USA 
addressing format.  Go ahead and select the Add button to see that this is true. Click on 
Cancel.

FILE EXPORTING / IMPORTING:



Import and Exporting is the process of exchanging data between application by way of text 
files. These text files are often referred to as ASCII files and contain separated text strings that
correspond to individual record fields. i.e. Last Name, First Name, Phone Number, etc. Most 
database and spreadsheet programs are capable of producing ASCII files containing their 
record information in separated fields.

The Importing and Exporting capabilities is quite flexible in Adr_Html. It is possible to specify 
the ordering of the fields within the file, and what character or character sequence separates 
each field. By ordering we can say the fields in the file will be "Last Name", "First Name", 
"Birthday", "Home Phone" or "First Name", "Last Name", "Home Phone", "Birthday". The field 
separator or delimiter indicates if a tab, comma, double quote comma, etc separates the fields
within the file.

Importing data into Adr_Html implies merging data. If you already have 15 records in 
Adr_Book and you Import an ASCII file with 10 records you will end up with a database 
containing 25 records.

The Import command can also be used to merge two Adr_Html database files. Adr_Html 
database files end with a .HDR extension. This extension indicates that a database file rather 
than an ASCII file is to be merged. 

With that general introduction and overview behind us, let's step through some examples. The 
sample Import file, import.dmp, should have been included with your installation.

1. Start by selecting New from the File menu. If a dialog box asks if you want to save 
changes, click on NO.

2. Select Import from the File menu. From the dialog box select Setup. We now need to 
describe this Import file. It has only four fields for each record and they are in the following 
order: First Name, Last Name, Work Phone, and Home Phone.  Each field is separated with a 
tab character. (Feel free to view import.dmp with any text editor)

3. Click on the Tab Radio Button to indicate this is our field separator. Since this is the default 
separator it is probably already selected. Click on the First_Name in the Adr_Book Fields List 
Box. It should become highlighted. Since this is the first field in our import file click on field 
<01> Skip of the Import File List Box. You should see First_Name copied into the Import File 
List Box. Next, click on Last_Name under the Adrbook List Box. Move this to the Import List 
Box by clicking on field <02> Skip. Move Work_Phone to field <03> Skip and Home_Phone to
field <04> Skip in a similar fashion. You have now described the format of the sample Import 
file. Click on OK.

4. You should now be back at the previous dialog box. Click on open. In the Open Dialog box 
that is presented you should see the file Import.dmp. Select this and click on OK. You should 
now see that four names have been added into Adr_Html.

Before leaving this section I want to demonstrate how database files can be imported. 
Database files are files like demo.hdr. Files that have .hdr extensions. As mentioned above 
Importing implies merging. This will demonstrate how you can merge multiple .hdr files. 

5. From the File menu select Import. Next click on Open. Down by List Files of Type click on
the down arrow.  You will see an entry Database Files (*.HDR). Click on it. You should see the
database file demo.hdr. Select this and click on OK. You should now see that the demo.hdr 
database file has been loaded and merged with your previously  imported records. You can 
use this method to merge any number of database files. I should point out that this is a little bit
of magic. The .hdr file extension indicates to Adr_Html that a database file is being imported. 



Any setup for importing files is ignored. If interested there is also a section in the On-line Help 
titled Merging Database Files that also explains this process.

6. Let's clean everything. Simply reload the demo.hdr file by selecting Open from the File 
Menu. Select No when asked if you want to save the changes. Click on demo.hdr and then 
select open. 

I am not including a detailed description of the Export process but it is identical to Importing 
except that your database file will be written to an ASCII file based on fields that you select 
and the specified field separator. There is one thing that should be noted about this Export 
process. If you select a subset of your database using the Find feature (described below), 
only those records currently selected will be written to your Export file.

FIND:

The Find feature of Adr_Book is a means of locating an individual record or a group of 
records. The find feature of Adr_Book works a little differently than the find feature in many 
other applications. Rather than simply locating the first record that meets a search request, 
Adr_Book will present at once all  the records that met a given search request. For example if 
you had 200 records in your database file and a search matched 50 records that had a ZIP 
CODE starting with "995" the address book would now display only those 50 records.  This 
has implications for writing Html Records.  Writing Html records after the search just described
would result in only 50 records being written. Those 50 records that matched a ZIP CODE 
starting with "995".

1. Select the Find... from the Find menu.  You could also use the Accelerator Key Ctrl+F. This
will bring up the Find  Simple Dialog Box.

2. In the Find What entry type 99.    Check the Zip check box.  Click Find It.

3.  You should see five names in the graphical address book.  

4. Now type Ctrl+L to clear the results of the search command. This will bring all 15 records 
back into the Address Book.

If you have stepped through this document you will have tested most of the features of Adr_Html 
and should know if this program will work for you. I hope that it will. If you have any questions or 
suggestions please send to me at:

Internet E-mail to mikeg@alaska.net  (This is actually the best way to contact me)
Alaska phone number (907) 278-1231

Michael Gardner
1231 Redwood Ct.
Anchorage AK 99508

Also be sure to check out the Brown Bear Software home page at:
http://www.alaska.net/~mikeg

This Homepage can always be used to find out about the latest developments.

April 8,  1996


